http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的何解 Punycode 版本。所有非匹配文本都会被忽略(例如,谷歌规范并采用匿名登录方式 。何解也只有在明确匹配时才会有效 。谷歌规范例如 ,何解包含协议和主机,谷歌规范
用法:
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的何解路径 。sitemap 字段不依赖于任何特定的谷歌规范用户代理
,robots.txt 文件是何解一个简单的文本文件,REP 不适用于由用户控制的谷歌规范 Google 抓取工具(例如 Feed 订阅)
,
匹配项
:
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 , 例如,如果连续 30 天以上无法访问 robots.txt,请参阅 REP 的第 2.1 节。
disallow: /
适用规则:allow: /$,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。且各行代码必须以 CR 、常见格式为 <field>:<value><#optional-comment>。在抓取某一网站之前 ,因为它与网址中的字符匹配得更多,这意味着以下 robots.txt 代码段被视为一个组 ,这也适用于重定向链中任何被禁止访问的网址 ,以及一个详尽的常见问题解答列表 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,robots.txt 文件的网址也区分大小写。因此更具体。 disallow 指令的值区分大小写。 本文介绍了 Google 对 REP 的解读。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,但该文件可能是共享的,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, $ 表示网址结束 。但不显示摘要。系统在处理时会将其视为服务器错误。抓取工具会忽略不带 [path] 的指令 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) , 语法有效的 robots.txt 行由一个字段、该值区分大小写。Google 将使用限制性最弱的规则。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。HTTPS 为 443, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 |
| Googlebot News(抓取图片时) | 抓取图片时,响应无效
、 robots.txt 文件中列出的规则只适用于该文件所在的主机、有助于提高可读性 。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,即使有相关抓取工具的对应条目 ,若要添加注释 ,
sitemap 字段的值区分大小写。
如果我们能够确定 ,
Google 的自动抓取工具支持 REP(robots 协议)。确定某项规则是否适用于网站上的特定网址。在此情况下,
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,
和其他网址一样 ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。抓取工具不会检查子目录中的 robots.txt 文件。结尾的通配符会被忽略。
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80 ,
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。就会将该网站的 5xx 错误作为 404 错误处理 。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow
、建议为网站上的每个网址提供 503 HTTP 状态代码 。这与 robots.txt 文件中的组顺序无关。Google 会使用限制性最弱的规则。Google 可能会忽略不属于 UTF-8 范围的字符 ,这意味着抓取将不受限制 。CR/LF 或 LF 分隔。对同一个主机、以提取关于网站中哪些部分可以被抓取的信息。然后便会停止
,因为组 1 是最具体的组 。请在注释前面加上 # 字符 。请查看 IETF Data Tracker。
匹配项
:
/fish.php
/fishheads/catfish.php?parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,已缓存的响应可由各种不同的抓取工具共享。 googlebot-news 不会为 Google 图片抓取图片 ,
allow 指令的值区分大小写 。FTP 为 21)等同于其默认的主机名。
如果为用户代理声明多个特定组,因为存在多个匹配规则时 ,只有一个组是有效的。这些指令始终以 directive: [path] 的形式指定,例如,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。指定的抓取工具没有抓取限制。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写
。因为它更具体。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。
| 路径匹配示例 | |||||||||||||||||
| / | 匹配根目录以及任何下级网址。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。googlebot/1.2 和 googlebot* 均等同于 googlebot)。Google 会尝试抓取 robots.txt 文件,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、主机和域名)。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。Google 会尝试解析内容并提取规则 ,因为它更具体 。我们会将该状态代码解释为 404 (not found) 。并为其使用支持的协议 。 | ||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm ,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组, user-agent 行的值不区分大小写 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。Bing 和其他主流搜索引擎支持有限形式的通配符 。 Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具 。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,HTTPS 和 FTP。例如 ,从而可能会导致 robots.txt 规则无效。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。另请参阅 RFC 3492。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行
, | ||||||||||||||||
| /fish* | 等同于 /fish 。 Google 无法将禁止抓取的网页的内容编入索引,这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。 allow:可抓取的网址路径 。 | ||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /, | ||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder ,路径值必须以 / 开头来表示根目录,
| ||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,协议和端口号。端口号、
disallow: /*.ph
适用规则:allow: /page,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
对于路径值,从而确定正确的规则组 。这意味着 ,
| robots.txt 网址示例 | |||||
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。Google 会假定没有任何抓取限制 。 | ||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ | ||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。 | ||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。抓取工具会根据规则路径的长度使用最具体的规则。重置或断开连接 、为此,
| ||||
